Jump to content

Watch Britney's Bizarre Filming Of 'Make Me'

Jordan Miller

Recommended Posts

  • Replies 572
  • Created
  • Last Reply

If you're talking about that golden thing she's probably not wearing it since it's in the clothes rack lol Do you remember all those crazy heels options she had for Work *****? They have tons of stuff at these shoots, the fact that it is there doesn't mean that she's using it.

Link to comment
5 minutes ago, It'sSamB!tch said:

She did some lovely choreo in Work *****: we didn't see her arriving at/leaving the studio as I recall.


We saw her a lot in the studio before the Work ***** shoot lol But as I said before she went a couple of times last month and I think those were for MMO (that day she was holding anti)

Link to comment
1 hour ago, I Think I'm Ready Now said:

For WB, they cutted out the sexiest scenes because she wanted it :tiffanynod: They won't do it if Britney doesn't ask to cut them

Well, what I understood about WB is not that they cut scenes, but that they didn't even do them in the first place, because she thought it was too much.

Perfume is the one that got all censored, after she had recorded everything.

Link to comment
  • Super Mods
55 minutes ago, kajcam said:

But she said that the interview one wasn't in the vide:awks:

Did she? I just heard her joking that its what she wears to lunch. Thats not confirming that its not in the video.

Link to comment

The one she uses in the interview it's not going to be in the video.

They are not showing it in a video before the video comes out, it's pointless I think.

She was probably testing some outfits and chose that one to mess around. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...

We noticed you're using an ad blocker  :ehum_britney_um_unsure_confused_what:

Thanks for visiting Exhale! Your support is greatly appreciated 💜  

Exhale survives through advertising revenue. Please, disable your ad block extension to help us and continue browsing Exhale. 🙏

I've disabled ad block